PSO V2 can’t connect

Sylverant is a homebrew open source server for Phantasy Star Online. Dreamcast users still play PSO online with this server even today! This is the official forum for both the online game server as well as the open source project itself. Feel free to post and get a gathering started online! We can also show you how to get connected!

Moderators: BlueCrab, Aleron Ives

Post Reply
miles
DCEmu Newbie
DCEmu Newbie
Posts: 9
Joined: Wed Dec 06, 2017 8:31 am
Has liked: 0
Been liked: 0

PSO V2 can’t connect

Post by miles » Mon May 27, 2019 7:41 pm

Good timing to all.
I’ve finally got a license copy NTSC-J copy of PSO v2. Now I’m trying to connect to sylverant using PSO patcher and get nothing. The problem is when I choose online mode game says me that settings are not set up yet and I need to complete registration in browser. At the same time when I start patched PSO pal-u from dreamshell it connects very well.
I tried all existing browsers, they connect to the internet very well, but jap region PSO can’t do this.
Could you advise me what to do to connect japan region PSO to sylverant?
Thanks a lot.


Отправлено с моего iPhone используя Tapatalk
User avatar
Aleron Ives
DCEmu Nutter
DCEmu Nutter
Posts: 805
Joined: Wed Jan 05, 2011 2:15 pm
Location: California
Has liked: 0
Been liked: 0
Contact:

Re: PSO V2 can’t connect

Post by Aleron Ives » Tue May 28, 2019 7:22 pm

The Japanese PSO disc seems to require special ISP settings that most browsers can't configure. Nobody seems to know how to make JPv2 happy. I've been able to use JPv2 online once my DC is already set up to take USv2 online, but people who try to set up JPv2 as their first disc can't get it to work for unknown reasons. If you can't figure it out, the only solution seems to be using US or EU discs, instead.
"Fear the HUnewearl."
Image
miles
DCEmu Newbie
DCEmu Newbie
Posts: 9
Joined: Wed Dec 06, 2017 8:31 am
Has liked: 0
Been liked: 0

Re: PSO V2 can’t connect

Post by miles » Tue May 28, 2019 10:16 pm

Aleron Ives wrote:The Japanese PSO disc seems to require special ISP settings that most browsers can't configure. Nobody seems to know how to make JPv2 happy. I've been able to use JPv2 online once my DC is already set up to take USv2 online, but people who try to set up JPv2 as their first disc can't get it to work for unknown reasons. If you can't figure it out, the only solution seems to be using US or EU discs, instead.
Thank you for reply.
It’s like a mystery :)
But I tried some ways, even resetting all settings and even setting up firstly US version, then JP and there’s no result unfortunately.
Ok, maybe someday someone will find solution :)


Отправлено с моего iPhone используя Tapatalk
miles
DCEmu Newbie
DCEmu Newbie
Posts: 9
Joined: Wed Dec 06, 2017 8:31 am
Has liked: 0
Been liked: 0

Re: PSO V2 can’t connect

Post by miles » Wed May 29, 2019 2:17 pm

Aleron Ives wrote:The Japanese PSO disc seems to require special ISP settings that most browsers can't configure. Nobody seems to know how to make JPv2 happy. I've been able to use JPv2 online once my DC is already set up to take USv2 online, but people who try to set up JPv2 as their first disc can't get it to work for unknown reasons. If you can't figure it out, the only solution seems to be using US or EU discs, instead.
Man, I did it! It works! Image


Отправлено с моего iPhone используя Tapatalk
User avatar
Aleron Ives
DCEmu Nutter
DCEmu Nutter
Posts: 805
Joined: Wed Jan 05, 2011 2:15 pm
Location: California
Has liked: 0
Been liked: 0
Contact:

Re: PSO V2 can’t connect

Post by Aleron Ives » Fri May 31, 2019 7:42 am

Which browsers did you use, and which settings did you configure? If you got JPv2 to work by itself, others would like to know. ;)
"Fear the HUnewearl."
Image
miles
DCEmu Newbie
DCEmu Newbie
Posts: 9
Joined: Wed Dec 06, 2017 8:31 am
Has liked: 0
Been liked: 0

Re: PSO V2 can’t connect

Post by miles » Sun Jun 02, 2019 2:07 am

Aleron Ives wrote:Which browsers did you use, and which settings did you configure? If you got JPv2 to work by itself, others would like to know. ;)
Just erased internal flash memory using flasher on xdp browser disc, then set up as usual with custom planetweb 2.6.
Then downloaded DreamKey 3.0 (found only gdi dump, so optimized it and started from hdd) and set up again with the same settings as in xdp. These browsers record settings in other blocks as I understood.
Then I followed your advice and registered firstly USv2, it had two ISPs, both are working.
Then I started JPv2 (after using sylverant PSO patcher 2.0), it connected right away :)


Отправлено с моего iPhone используя Tapatalk
Post Reply