Ship Palmacosta

Sylverant is a homebrew open source server for Phantasy Star Online. Dreamcast users still play PSO online with this server even today! This is the official forum for both the online game server as well as the open source project itself. Feel free to post and get a gathering started online! We can also show you how to get connected!

Moderators: BlueCrab, Aleron Ives

Post Reply
User avatar
BlueCrab
The Crabby Overlord
The Crabby Overlord
Posts: 5520
Joined: Mon May 27, 2002 11:31 am
Location: Sailing the Skies of Arcadia
Has thanked: 6 times
Been thanked: 29 times
Contact:

Re: Ship Palmacosta

Post by BlueCrab » Mon Jan 05, 2015 9:59 pm

Didi wrote:Else that needs an update is there in the wiki where you put the Instructions on how to configure Sylverant Ship Server in GC quest configuration you said you would M 1 to episode 1 and 2 for the second episode, when in fact is W so you just inform.
I don't understand what you're trying to say? The map files have absolutely nothing to do with quests at all. :?:
User avatar
Didi
DCEmu Freak
DCEmu Freak
Posts: 70
Joined: Mon Sep 30, 2013 9:44 am
Location: Brasil
Has thanked: 0
Been thanked: 0
Contact:

Re: Ship Palmacosta

Post by Didi » Tue Jan 06, 2015 6:22 am

BlueCrab wrote:
Didi wrote:Else that needs an update is there in the wiki where you put the Instructions on how to configure Sylverant Ship Server in GC quest configuration you said you would M 1 to episode 1 and 2 for the second episode, when in fact is W so you just inform.
I don't understand what you're trying to say? The map files have absolutely nothing to do with quests at all. :?:
Sorry, is not quest, I'll get the the following page snippet of text
...For Gamecube, you will have maps for episode 1 and episode 2. For this, the filenames have changed to mwxyz.dat and mwxyz_o.dat. x, y, and z are as they are for the Dreamcast version, and m is 1 for episode 1 or 2 for episode 2....
https://code.google.com/p/sylverant/wik ... erantShips
The m which is underline should be w, is not it?
Passatempo favorito: Jogar os diversos PSOs
Image
User avatar
BlueCrab
The Crabby Overlord
The Crabby Overlord
Posts: 5520
Joined: Mon May 27, 2002 11:31 am
Location: Sailing the Skies of Arcadia
Has thanked: 6 times
Been thanked: 29 times
Contact:

Re: Ship Palmacosta

Post by BlueCrab » Tue Jan 06, 2015 9:30 am

Didi wrote:
BlueCrab wrote:
Didi wrote:Else that needs an update is there in the wiki where you put the Instructions on how to configure Sylverant Ship Server in GC quest configuration you said you would M 1 to episode 1 and 2 for the second episode, when in fact is W so you just inform.
I don't understand what you're trying to say? The map files have absolutely nothing to do with quests at all. :?:
Sorry, is not quest, I'll get the the following page snippet of text
...For Gamecube, you will have maps for episode 1 and episode 2. For this, the filenames have changed to mwxyz.dat and mwxyz_o.dat. x, y, and z are as they are for the Dreamcast version, and m is 1 for episode 1 or 2 for episode 2....
https://code.google.com/p/sylverant/wik ... erantShips
The m which is underline should be w, is not it?
Yes, you're correct (and I apparently only flubbed it on the Gamecube part, because the Blue Burst part below does have w as it should be). I'll fix the mistake there...
User avatar
Didi
DCEmu Freak
DCEmu Freak
Posts: 70
Joined: Mon Sep 30, 2013 9:44 am
Location: Brasil
Has thanked: 0
Been thanked: 0
Contact:

Re: Ship Palmacosta

Post by Didi » Thu Jan 15, 2015 5:08 pm

Blue, You did not answer my last pm, you saw?
Passatempo favorito: Jogar os diversos PSOs
Image
User avatar
BlueCrab
The Crabby Overlord
The Crabby Overlord
Posts: 5520
Joined: Mon May 27, 2002 11:31 am
Location: Sailing the Skies of Arcadia
Has thanked: 6 times
Been thanked: 29 times
Contact:

Re: Ship Palmacosta

Post by BlueCrab » Sat Jan 17, 2015 2:05 pm

Sorry about that. I've been really busy this week, so I hadn't really had a chance to look at the message.
User avatar
Didi
DCEmu Freak
DCEmu Freak
Posts: 70
Joined: Mon Sep 30, 2013 9:44 am
Location: Brasil
Has thanked: 0
Been thanked: 0
Contact:

Re: Ship Palmacosta

Post by Didi » Mon Feb 09, 2015 11:52 am

I noticed a strange behavior, the file ship-config configuration is in this way

Code: Select all

		<bbmaps dir="config/bb/maps/" />
		<v2maps dir="config/v2/maps/" />
		<gcmaps dir="config/gc/maps/" />
and the log file it happens

Code: Select all

[2015:02:09: 17:52:06.015]: v2 Map Directory: config/v2/maps/
[2015:02:09: 17:52:06.015]: GC Map Directory: config/bb/maps/
[2015:02:09: 17:52:06.015]: BB Map Directory: config/bb/maps/
Note that despite the ship_config configuration file are pointing to their GC, the log shows that the path of GC is the BB directory, why?
it seems that what I put in BB holds for him and for the GC, making the setting for the directory GC useless
Passatempo favorito: Jogar os diversos PSOs
Image
User avatar
BlueCrab
The Crabby Overlord
The Crabby Overlord
Posts: 5520
Joined: Mon May 27, 2002 11:31 am
Location: Sailing the Skies of Arcadia
Has thanked: 6 times
Been thanked: 29 times
Contact:

Re: Ship Palmacosta

Post by BlueCrab » Mon Feb 09, 2015 7:29 pm

That's certainly strange... Try doing a "make clean" in both the ship_server and libsylverant directories, then doing a "make && make install" in both (libsylverant first, then ship_server). See if that fixes it.
User avatar
Didi
DCEmu Freak
DCEmu Freak
Posts: 70
Joined: Mon Sep 30, 2013 9:44 am
Location: Brasil
Has thanked: 0
Been thanked: 0
Contact:

Re: Ship Palmacosta

Post by Didi » Tue Feb 10, 2015 6:10 pm

BlueCrab wrote:That's certainly strange... Try doing a "make clean" in both the ship_server and libsylverant directories, then doing a "make && make install" in both (libsylverant first, then ship_server). See if that fixes it.
I did it, yet the error continues, and looked in the log since we began with the ship and always had the same error, does the problem may be in the certificate file?
Passatempo favorito: Jogar os diversos PSOs
Image
User avatar
BlueCrab
The Crabby Overlord
The Crabby Overlord
Posts: 5520
Joined: Mon May 27, 2002 11:31 am
Location: Sailing the Skies of Arcadia
Has thanked: 6 times
Been thanked: 29 times
Contact:

Re: Ship Palmacosta

Post by BlueCrab » Tue Feb 10, 2015 7:25 pm

That has nothing to do with the certificates at all, no.
User avatar
Didi
DCEmu Freak
DCEmu Freak
Posts: 70
Joined: Mon Sep 30, 2013 9:44 am
Location: Brasil
Has thanked: 0
Been thanked: 0
Contact:

Re: Ship Palmacosta

Post by Didi » Wed Feb 11, 2015 5:03 am

BlueCrab wrote:That has nothing to do with the certificates at all, no.
What the next step will be to try to resolve this problem? Is it this problem that is preventing the GC players enter the ship?
Passatempo favorito: Jogar os diversos PSOs
Image
User avatar
BlueCrab
The Crabby Overlord
The Crabby Overlord
Posts: 5520
Joined: Mon May 27, 2002 11:31 am
Location: Sailing the Skies of Arcadia
Has thanked: 6 times
Been thanked: 29 times
Contact:

Re: Ship Palmacosta

Post by BlueCrab » Wed Feb 11, 2015 8:07 am

Considering the maps don't have to be configured at all, I'd highly doubt it'd prevent them from getting on the ship at all.

As for how to fix it, I honestly don't have any idea. It's obviously working fine on my end. I'll have to take a look at the code a bit more closely and make sure there's not any weird/wonky ways for that to happen...
User avatar
Didi
DCEmu Freak
DCEmu Freak
Posts: 70
Joined: Mon Sep 30, 2013 9:44 am
Location: Brasil
Has thanked: 0
Been thanked: 0
Contact:

Re: Ship Palmacosta

Post by Didi » Sat Aug 29, 2015 12:38 pm

The ship is back!!!!!
Any problems just report here.
Passatempo favorito: Jogar os diversos PSOs
Image
User avatar
TulioAdriano
DCEmu Freak
DCEmu Freak
Posts: 56
Joined: Tue Aug 18, 2015 9:32 am
Has thanked: 0
Been thanked: 1 time

Re: Ship Palmacosta

Post by TulioAdriano » Sat Aug 29, 2015 3:42 pm

Hi Didi, Obrigado for bringing it in.

Unfortunately while I was logged in, I got a severe lag and my PSO hanged.

Now I can't login sylverant anymore because it says my guildcard is already online.

Can you help? My guildcard is 15408.

Abraços, PM me if needed.
There are 10 types of people. Those who understand binaries and those who don't.
User avatar
BlueCrab
The Crabby Overlord
The Crabby Overlord
Posts: 5520
Joined: Mon May 27, 2002 11:31 am
Location: Sailing the Skies of Arcadia
Has thanked: 6 times
Been thanked: 29 times
Contact:

Re: Ship Palmacosta

Post by BlueCrab » Sat Aug 29, 2015 4:53 pm

The "Guildcard is already online" issue should always resolve itself within a few minutes (and I'm sure it has by now for you). Basically, once you drop from the ship, there should only be about a 2-4 minute window where that issue can come up (i.e, before the ship realizes you've pinged out, disconnects its side of your connection, and informs the shipgate you've disconnected).

The only person who could really do anything about that in the meantime would be me, by the way. :wink:
User avatar
TulioAdriano
DCEmu Freak
DCEmu Freak
Posts: 56
Joined: Tue Aug 18, 2015 9:32 am
Has thanked: 0
Been thanked: 1 time

Re: Ship Palmacosta

Post by TulioAdriano » Sat Aug 29, 2015 5:02 pm

Yeah, it's still stuck... This has been gone for over an hour and a half already... If you check the server stats on your website, the ship palmacosta is stuck on the same stats for a while now. 6 hunters online 1 team active.

I think something got stuck there. Thankfully I was connected on the PC... if that happened to my Dreamcast Guildcard I'd have freaked out! :D

Can you help?
There are 10 types of people. Those who understand binaries and those who don't.
User avatar
Didi
DCEmu Freak
DCEmu Freak
Posts: 70
Joined: Mon Sep 30, 2013 9:44 am
Location: Brasil
Has thanked: 0
Been thanked: 0
Contact:

Re: Ship Palmacosta

Post by Didi » Sat Aug 29, 2015 5:50 pm

Hi Tulio! I Saw your pm. Welcome to the ship!!!
I can restart the ship if your problem still continue.
Passatempo favorito: Jogar os diversos PSOs
Image
User avatar
TulioAdriano
DCEmu Freak
DCEmu Freak
Posts: 56
Joined: Tue Aug 18, 2015 9:32 am
Has thanked: 0
Been thanked: 1 time

Re: Ship Palmacosta

Post by TulioAdriano » Sat Aug 29, 2015 5:56 pm

Yep, the problem still there... It's been over 2 hours since I can't login again due to "being already online". The ship status on Sylverant.net still shows the same thing... 6 hunters online, 1 team active. I think all those guildcards may have the same issue that I do, except that they haven't come here to report. ^^

I hope that can clear it up from the shipgate, otherwise, only BlueCrab can rescue us!

Thanks a lot!
There are 10 types of people. Those who understand binaries and those who don't.
User avatar
BlueCrab
The Crabby Overlord
The Crabby Overlord
Posts: 5520
Joined: Mon May 27, 2002 11:31 am
Location: Sailing the Skies of Arcadia
Has thanked: 6 times
Been thanked: 29 times
Contact:

Re: Ship Palmacosta

Post by BlueCrab » Sat Aug 29, 2015 6:24 pm

Ah... That most likely means the ship has crashed in some manner. They'll have to restart it, but in the mean time I'll clear your online status from the backend.

Didi, make sure everything is up to date. There's been a bit of changes to the ship code since you guys last had it up, and there's obviously something wrong with your running instance if someone's been stuck without pinging out for that long.

EDIT: You should be able to log on now.
User avatar
TulioAdriano
DCEmu Freak
DCEmu Freak
Posts: 56
Joined: Tue Aug 18, 2015 9:32 am
Has thanked: 0
Been thanked: 1 time

Re: Ship Palmacosta

Post by TulioAdriano » Sat Aug 29, 2015 6:39 pm

Ah, that did it! My hero! :)

Online again! Ah, the joy! The joy!

Thank you!
There are 10 types of people. Those who understand binaries and those who don't.
henkus
DCEmu Newbie
DCEmu Newbie
Posts: 2
Joined: Sat Aug 29, 2015 7:52 pm
Has thanked: 0
Been thanked: 0

Re: Ship Palmacosta

Post by henkus » Sat Aug 29, 2015 8:00 pm

New forum user here, not a new PSO player.

Today i logged in on PSO v2 PC and saw a new ship. Great i thought (it was palma costa)
There were even 5 others there. I just had to go there , right?

Well i joined a vhard game to help low lvls and what happened next is something i had never seen before.
I joined an empty game and I had to force kill pso.exe. Wouldnt go back to the lobby.
Since then i have not been able to log back on. It says 'guildcard already online'.
A friend of mine has the same issue.

This all happened around 2215 GMT +1.
We played BB cmode on ephinea meanwhile but I can still not logon.
Seems that ship doesn't time me out..

Can anyone help me with this?
Post Reply