DreamShell issues

This forum is for discussion pertaining to homebrew and indie software for the Dreamcast, such as homebrew games, emulators/interpreters, and other homebrew software/applications. Porting requests and developmental ideas are not to be made here; you can make those here. If you need any help burning discs for homebrew software, this is the place to ask as well.
Post Reply
User avatar
DC Developer
DC Developer
Posts: 121
Joined: Fri Dec 14, 2007 1:56 am
Location: California
Has liked: 0
Been liked: 0

DreamShell issues

Post by Corbin » Fri Feb 05, 2016 8:43 pm

Hi there again,

After all of these years, I finally caved in and bought a SD card reader for my Dreamcast. Previously, every single build of everything I've ever compiled was burned tediously to disc. I was afraid of the reader going out so I got it all set up.

Pretty neat! Trying to get used to it, but it seems intuitive so far.

My main interest was the ISO loader; because my engine generates an ELF, which I convert to a scrambled BIN. From there, I run mkisofs. Generates an ISO (and a CDI), but it looks like CDIs cannot be loaded. So that's fine and all. I copy the ISO to the SD card. For the record, this is a 16GB SD Card from a Nintendo 3DS, formatted in Windows to FAT32.

When I attempt to boot the ISO via DreamShell's Iso Loader, I encounter an Unhandled Exception. I can't see jack shit that way, it all looks like DreamShell debugger stuff - nothing remotely indicating my program is attempting to start.

The ISO [CDI] loads fine on a Dreamcast with a CDR, and nullDC as well - I'm not sure why I can't load it via DreamShell.

If I can get some assistance, that'd be great! Also, how do I enable debugging information that comes from the Ethernet Adapter? It'll help with my engine, but this Dreamshell stuff...no clue there.

Thanks for the help!

To circumvent this, I went ahead and generated my BIN from the ELF, but I left it unscrambled and popped it in the directory that my engine resides. I copied the whole thing over, used File Manager to load it up, and it seems to work...the problem is that the screen is cut off so I can't see anything, and it looks like it crashes right away.. doesn't do that when burned to a CD-ROM.

So, I suppose I solved my problem, but is it unwise to load programs from DreamShell? Maybe I'm leaving something out?
Post Reply