Search found 95 matches

by showka
Tue Oct 25, 2016 8:35 pm
Forum: Programming Discussion
Topic: Trying a gcc 7 toolchain
Replies: 8
Views: 1892

Re: Trying a gcc 7 toolchain

Where should this get run exactly? In other words what is expected to exist in $TOOLCHAIN_DIR? I'm guessing gcc_fix.h has to be there, but where are you getting `include/akumu/stl?` When I run this script, I get an error running ../combined/configure (on line 37): /tmp/dc_toolchain_build/build$ CFLA...
by showka
Tue Sep 13, 2016 8:19 pm
Forum: Front Page News and Forum Guidelines
Topic: Redspotgames Domain Expires
Replies: 7
Views: 3963

Re: Redspotgames Domain Expires

For some reason this makes me feel very sad / old. :(
by showka
Wed Sep 30, 2015 8:59 am
Forum: Gaming Forum
Topic: Any decent sites for PSP emulators / hacking tools?
Replies: 2
Views: 1262

Any decent sites for PSP emulators / hacking tools?

For years I've heard about all the cool hacks and emulators available for the PSP. Well I recently bought one and so far I've updated it with custom firmware and been able to store all of my games onto the memory card, which is cool. What I'm finding sad and a bit obnoxious is how no decent sites se...
by showka
Wed Feb 05, 2014 8:18 pm
Forum: Programming Discussion
Topic: Cygwin setup error
Replies: 5
Views: 668

Re: Cygwin setup error

Try uninstalling cygwin completely and then reinstalling.

I'm not sure if you're in a position to do this but you might want to consider installing Lubuntu or some other Linux on this machine and dual booting. You'll find the toolchain much easier to set up there than in Windows anyway.
by showka
Tue Feb 04, 2014 8:43 pm
Forum: Programming Discussion
Topic: Cygwin setup error
Replies: 5
Views: 668

Re: Cygwin setup error

It looks like your install of Cygwin is borked. What version of Windows and Cygwin are you using (as in 32 or 64 bits)?
by showka
Sun Feb 02, 2014 7:29 pm
Forum: Programming Discussion
Topic: Setup Error
Replies: 3
Views: 585

Re: Setup Error

By the way, I tried to build a toolchain today on my new Surface tablet using the 64-bit version of Cygwin and ran into troubles while on one of the last steps of compiling the SH-4 version of GCC. I uninstalled Cygwin completely (by which I mean I just deleted the C:\Cygwin64 directory) and tried i...
by showka
Sat Feb 01, 2014 1:39 am
Forum: Programming Discussion
Topic: Setup Error
Replies: 3
Views: 585

Re: Setup Error

The most important step in building the toolchain is to make sure you get all of the dependencies right. In Windows with Cygwin, the easiest way to do that is to open a Windows command prompt, cd into the directory with the Cygwin installer exe, and run the following: setup-x86.exe --quiet-mode --pa...
by showka
Sun Jan 26, 2014 12:06 am
Forum: Programming Discussion
Topic: DC Dev ISO R4
Replies: 66
Views: 26507

Re: DC Dev ISO R4

To elaborate a bit, for me historically the hardest part was always just getting the toolchain up and working. Last year I wrote a bash script to do this automatically in Ubuntu, but figured it wasn't a good solution in Cygwin since the installer used that gui. Well I recently discovered it was poss...
by showka
Sun Jan 19, 2014 6:45 pm
Forum: Programming Discussion
Topic: DC Dev ISO R4
Replies: 66
Views: 26507

Re: DC Dev ISO R4

@Christuserloeser

Is the source code to this available anywhere? What tooling did it use?
by showka
Sun Jan 19, 2014 3:40 pm
Forum: Programming Discussion
Topic: Getting weird errors using snd_stream_poll
Replies: 25
Views: 1466

Re: Getting weird errors using snd_stream_poll

So today I setup NullDC and noticed I couldn't make my program fail the same way. So I grabbed the vorbis.elf and again, it worked fine. I fished out the cdi2nero.exe from some ancient hard drive and burned it, and whaddya know, it works. Previously when I'd tried this, I had started with the dcload...
by showka
Wed Jan 15, 2014 11:18 pm
Forum: Programming Discussion
Topic: Getting weird errors using snd_stream_poll
Replies: 25
Views: 1466

Re: Getting weird errors using snd_stream_poll

If anyone out there can try to recreate, particularly someone with a toolchain they built themselves either in Cygwin or in a Linux flavor (preferrably Ubuntu) using GCC, I'd greatly appreciate it. The steps to recreate are relatively simple. 1. Download this ogg file and save it to KallistiOS/examp...
by showka
Wed Jan 15, 2014 7:44 pm
Forum: Programming Discussion
Topic: Getting weird errors using snd_stream_poll
Replies: 25
Views: 1466

Re: Getting weird errors using snd_stream_poll

In case I'd mistated it: my ethernet cable goes from my desktop straight to the Dreamcast.

Today I refreshed and rebuilt KallistiOS and kost-ports on my netbook and ran a few demos. The behavior of the hello-ogg example was identical. It works with the romdisk, but fails reading from /pc.
by showka
Tue Jan 14, 2014 8:21 pm
Forum: Programming Discussion
Topic: Getting weird errors using snd_stream_poll
Replies: 25
Views: 1466

Re: Getting weird errors using snd_stream_poll

Just recompiled my toolchain in Linux, bringing gcc from 4.7.0 to 4.8.0, the recompiled KallistiOS and kos-ports. Same. Exact. Problem. I then brought out my old Dreamcast, swapped out the BBA from the new one to the old one. Same thing. If it's working for you, then I wonder if this means the speed...
by showka
Mon Jan 13, 2014 9:08 pm
Forum: Programming Discussion
Topic: Getting weird errors using snd_stream_poll
Replies: 25
Views: 1466

Re: Getting weird errors using snd_stream_poll

Well... doo doo. At this point I'm not really sure what to do; this may be difficult to believe but I've already rebuilt KOS and the ports on both Windows and on my Ubuntu VM (which can also talk to the Dreamcast). Should I also rebuild the toolchains (i.e. stuff like the compilers)? I last did this...
by showka
Mon Jan 13, 2014 6:00 pm
Forum: Programming Discussion
Topic: Getting weird errors using snd_stream_poll
Replies: 25
Views: 1466

Re: Getting weird errors using snd_stream_poll

So today I started the Dreamcast with the dcload-ip disc, then swapped in a new CDR with an oggfile on it and ran a version of vorbistest.c which read from the cd drive (there were no printf statements or other alterations). The program appeared to hang and would not end when I pressed start, consta...
by showka
Mon Jan 13, 2014 8:59 am
Forum: Programming Discussion
Topic: Getting weird errors using snd_stream_poll
Replies: 25
Views: 1466

Re: Getting weird errors using snd_stream_poll

Most of the time when reading a file, your request gets handled immediately on KOS -- there generally is no blocking that happens (except with the /pc filesystem. If reading from /pc blocks, then wouldn't it follow that trying to read large chunks from it from one thread while playing sound, drawin...
by showka
Mon Jan 13, 2014 12:40 am
Forum: Programming Discussion
Topic: Getting weird errors using snd_stream_poll
Replies: 25
Views: 1466

Re: Getting weird errors using snd_stream_poll

I was able to get eliminate crashes from the program I've been describing by moving the sound poll routines in the main thread (though the wave file reader seems broken in other ways). It seems that plus the stream size of 8kb has helped immensely, though if I decrease it too much the reader thread ...
by showka
Sun Jan 12, 2014 11:56 pm
Forum: Programming Discussion
Topic: Getting weird errors using snd_stream_poll
Replies: 25
Views: 1466

Re: Getting weird errors using snd_stream_poll

Hey - a bit of good news. Since you suggested that the size of the buffers was important, I realized I had been setting them to SND_STREAM_BUFFER_MAX, which I believe is something like 80kb. I pulled way back on that and set it down to 8kb and the results were much prettier and things generally seem...
by showka
Sun Jan 12, 2014 11:48 pm
Forum: Programming Discussion
Topic: Getting weird errors using snd_stream_poll
Replies: 25
Views: 1466

Re: Getting weird errors using snd_stream_poll

In theory, there shouldn't really be any issues with reading a file in one thread and doing other things in another thread (assuming there's nothing accessing the VFS in the other thread -- the VFS is explicitly NOT thread safe, which is something I should fix at some point). You shouldn't have to ...
by showka
Sun Jan 12, 2014 11:18 pm
Forum: Programming Discussion
Topic: Getting weird errors using snd_stream_poll
Replies: 25
Views: 1466

Re: Getting weird errors using snd_stream_poll

I also just realized that if a location on the pc is used, the vorbis test will fail as well. It plays the first few seconds alright, then begins repeating the same audio chunk in an endless loop. Is the ethernet cable just too slow for this kind of thing? Despite the fact I payed a ton for it, my B...