Issues Connecting with PSOv2 HELP!

Sylverant is a homebrew open source server for Phantasy Star Online. Dreamcast users still play PSO online with this server even today! This is the official forum for both the online game server as well as the open source project itself. Feel free to post and get a gathering started online! We can also show you how to get connected!

Moderators: BlueCrab, Aleron Ives

Post Reply
DuffMan757
DCEmu Newbie
DCEmu Newbie
Posts: 2
Joined: Tue Mar 07, 2017 12:19 pm

Issues Connecting with PSOv2 HELP!

Post by DuffMan757 » Tue Mar 07, 2017 1:18 pm

So I purchased a Dreampi Kit from PCWizard and got everything setup and it seems to be working off and on. I have a legit copy of US PSOv2 but I use the IVES PATCHED ENHANCED VERSION to Connect and Play. My DreamPi has no trouble at all dialing up and connecting and has internet access via Planet Web Browser. But seem like im having intermittent issues when connecting to the PSO Server, it will dialup and connect but it will just hang showing the PSO lobby background and I will not get the ship select screen at all. I have successfully got on befor with no problems maybe like a total of 3 times in the last week but now it seems to do it all the time! Thought it could be a DMZ issue but I have used 3 different routers (Apple Time Capsule, Netgear, TP-Link) so far with the DMZ setup properly with the dreamcast IP of x.x.x.98 but still the same issue. I have searched all the forums and have seen ppl with similar issues but the threads offer no help. I can see the Dreamcast IP (x.x.x.98) tagged with the MAC of the DreamPi in the ARP List in the router config so its def connected with the proper ip. Any advise would be greatly appreciated ! I just want to play some PSOv2 ..sadface

Did some reading seem like PSO doesn't even need a DMZ setup to play?


Things I have tried to no avail:
Swapped Routers (Turned Off/ Disabled Security Firewall as well thinking it Ports being blocked) still no joy
Formatted and Reloaded SD Card with DreamPi Image 1.6
Swapped out Ethernet cables

Also using a USB LVI if that makes any difference ....

Made this same post on Dreamcast-talk forum as well.
DuffMan757
DCEmu Newbie
DCEmu Newbie
Posts: 2
Joined: Tue Mar 07, 2017 12:19 pm

Re: Issues Connecting with PSOv2 HELP!

Post by DuffMan757 » Tue Mar 07, 2017 1:54 pm

Also have power cycled everything (Dreamcast, DreamPi, Router, Switch, Cable Modem) multiple times.

Tried using the PSO Patcher Disc w/ Legit Copy of PSOv2 with no success
Post Reply