DCEmulation

dreamcast development • homebrew software • hardware hacking • indie games • emulators • and more!
Back to main site
It is currently Thu Mar 30, 2017 1:28 pm

All times are UTC - 8 hours [ DST ]




Post new topic Reply to topic  [ 8 posts ] 
Author Message
 Post subject: Regarding Wii/Devolution
PostPosted: Sat May 28, 2016 8:16 pm 
Offline
The Crabby Overlord
The Crabby Overlord
User avatar

Joined: Mon May 27, 2002 9:31 am
Posts: 5126
Below is what I've recently posted over on the website regarding problems connecting to Sylverant on a Wii using Devolution. I do not want this topic to become a flamefest, so please do not treat it as such. Any such posts will be deleted.

It came to my attention a couple of weeks ago that Wii users were unable to connect to the server using Devolution in the normal manner prescribed by it’s author tueidj. Being that I haven’t changed anything in the Sylverant code in a while directly related to logging in with the Gamecube version, I was naturally curious as to what was going on. To this end, I reached out to tueidj regarding the matter.

Upon contacting tueidj, he informed me that he had effectively blacklisted any traffic from his server to Sylverant (by a process known as null-routing any connections). The effect being that he blocked all Wii users from connecting to Sylverant unless they set up their own PPP emulation servers to do so. As of now tueidj is still null-routing connections to the IP address for Sylverant (if you were to specify 0 for a phone number and specify Sylverant’s IP for the DNS server), but connections that normally would go to Sylverant automatically (using 2 for the phone number) are being now directed to l33tserv instead. tueidj took this action without contacting anyone associated with Sylverant and with no warning whatsoever.

I have had nothing but respect for tueidj up until this point — he created Devolution and has hosted the requisite PPP emulation server for many years without any problems. I also respect that most Devolution traffic generally goes through his server and he can do with that server as he pleases. However, null-routing the traffic bound for Sylverant (and subsequently redirecting it to l33tserv) without even the decency to notify me is not exactly deserving of respect. Out of full disclosure, I should also mention the reason that tueidj has taken this action: he got into an argument with Aleron Ives on the forum (over something completely pointless) and I chimed in to ask everyone to chill out. That is it.

I have held up on writing this post for about a week after I found out about the issue, hoping that an amicable conclusion to the situation could be reached. However, it appears at this point that there will be no amicable conclusion to the issue with tueidj, especially being that traffic is now being redirected to l33tserv. Unfortunately, the software that has been discussed previously to set up a PPP emulation server is horribly out of date and does not build nor work properly on the OS I have set up on the server here. This unfortunately means that until I can develop a replacement for that PPP emulation software (I have begun on this task about a week ago now), nobody will be able to connect with the Wii to Sylverant (unless someone else sets up the PPP emulation server software successfully).


Top
 Profile  
Reply with quote  
PostPosted: Sat May 28, 2016 10:01 pm 
Offline
DCEmu Freak
DCEmu Freak
User avatar

Joined: Wed Jan 13, 2016 6:03 am
Posts: 51
So this is what's happening behind the scenes. Welp, guess I won't be playing on Sylverant (since I can only play on weekends) until Devo can connect to it again. The Wii is my go-to system now when I wanna play GC games, especially for PSO. Hope this gets fixed soon because I miss Sylverant.

_________________
My Hunters:
Chadha Birdy (RAcast, ORAN - Main) - Lv 140
Metatron (HUcast, SKYLY) - Lv 80
Shaider (RAmar, PURPLENUM) - Lv 91

Steam, XBL, PSN - bytemedeep
Skype - johann.bird


Top
 Profile  
Reply with quote  
PostPosted: Sun May 29, 2016 1:37 am 
Offline
Psychotic DCEmu
Psychotic DCEmu
User avatar

Joined: Wed Jan 05, 2011 1:15 pm
Posts: 683
Location: California
Yeah, we're all hoping that BlueCrab will have the software set up to bypass the blockade soon.

_________________
"Fear the HUnewearl."
Image


Top
 Profile  
Reply with quote  
PostPosted: Mon May 30, 2016 10:58 am 
Offline
The Crabby Overlord
The Crabby Overlord
User avatar

Joined: Mon May 27, 2002 9:31 am
Posts: 5126
And... Thanks to some help with testing last night from a few server members, we now have a working PPP emulation server setup.

All you should need to change from your normal Devolution provider options are as follows:
Username: sylverant
Password: pso
Phone Number: 74623185647463

I'd suggest using multiple provider options if you wish to use different servers, since it's more work to put that phone number in correctly than I would really like...


Top
 Profile  
Reply with quote  
PostPosted: Sat Jun 04, 2016 12:09 pm 
Offline
DCEmu Newbie
DCEmu Newbie

Joined: Mon May 16, 2016 1:21 pm
Posts: 4
Just wondering, is there any tim schedule for this new PPP emulation server ?
I am asking because I tried today without any result and I don't think I messed up the provider setup.


Top
 Profile  
Reply with quote  
PostPosted: Sat Jun 04, 2016 1:12 pm 
Offline
The Crabby Overlord
The Crabby Overlord
User avatar

Joined: Mon May 27, 2002 9:31 am
Posts: 5126
redclad wrote:
Just wondering, is there any tim schedule for this new PPP emulation server ?
I am asking because I tried today without any result and I don't think I messed up the provider setup.
The server is up and running and hasn't been down. Double-check your configuration settings against what's my post up above, because it should be working just fine.

And no, there's no timetable for the new PPP emulator I'm writing. Unfortunately, real life tends to dictate to me that I won't have any time to work on things. :?


Top
 Profile  
Reply with quote  
PostPosted: Sun Jun 05, 2016 2:05 am 
Offline
DCEmu Newbie
DCEmu Newbie

Joined: Mon May 16, 2016 1:21 pm
Posts: 4
I feel a little bit ashamed now because I wrote sy!verant instead of sylverant. :oops:
It's not easy to see the difference with this font and the screen resolution ^^'
Since I tried twice it means I did it wrong twice (l and ! are on both sides of the m, at least in my version of pso).

It's working fine, sorry for asking.


Top
 Profile  
Reply with quote  
PostPosted: Sun Jun 05, 2016 7:47 am 
Offline
The Crabby Overlord
The Crabby Overlord
User avatar

Joined: Mon May 27, 2002 9:31 am
Posts: 5126
redclad wrote:
I feel a little bit ashamed now because I wrote sy!verant instead of sylverant. :oops:
It's not easy to see the difference with this font and the screen resolution ^^'
Since I tried twice it means I did it wrong twice (l and ! are on both sides of the m, at least in my version of pso).

It's working fine, sorry for asking.
I'm glad it was something simple. Good to hear you got it working. :)


Top
 Profile  
Reply with quote  
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 8 posts ] 

All times are UTC - 8 hours [ DST ]


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group