DCEmulation

The Dreamcast Homebrew Community Online
Back to main site
It is currently Sat Jul 26, 2014 10:12 am

All times are UTC - 8 hours [ DST ]




Post new topic Reply to topic  [ 12 posts ] 
Author Message
PostPosted: Thu Apr 12, 2012 3:20 am 
Offline
DCEmu Cool Newbie
DCEmu Cool Newbie

Joined: Tue Mar 13, 2012 12:23 pm
Posts: 12
The problem appeard the last days.

If i run a team noone is able to join me.
First i thought this is not my problem, cause all players where on DC dialup but since Rolf had the same prob with PC
tonight it might be on my side ...
I can join all other teams without any probs.
I did not change anything over the last weeks:

DC (original)v2 PAL, BBA
no patcher

And the problem seems to be located to ultimate games.
I had testet it with another dialup mashine in normal mode, and there where no problems.

I ll try it today with the patcher, if anyone is aboard ...

regards

roman
(DJ!NGESKHAN)


Top
 Profile  
 
PostPosted: Thu Apr 12, 2012 5:37 am 
Offline
Insane DCEmu
Insane DCEmu
User avatar

Joined: Mon Oct 27, 2008 4:47 pm
Posts: 252
When others try and join your game, what message do they get?
The players that can't enter are on dc,pc or gc?
Does this happen on all ships?
Why do you say difficulty is an issue, does changing the difficulty setting to normal/hard/vhard makes the game joinable?
Did this started happening recently and only recently? (bluecrab might have changed something, but only he can say)

If am avaiable later (in 7 hours) i might enter to check the problem myself.

_________________
Image


Top
 Profile  
 
PostPosted: Thu Apr 12, 2012 5:47 am 
Offline
The Crabby Overlord
The Crabby Overlord
User avatar

Joined: Mon May 27, 2002 9:31 am
Posts: 4097
I haven't changed anything recently with regard to joining games on the DC or PC.

I'm guessing the issue is related to lag in some way, but of course, I really don't know. Its rather difficult to debug problems like this, unfortunately. :?


Top
 Profile  
 
PostPosted: Thu Apr 12, 2012 5:52 am 
Offline
DCEmu Cool Newbie
DCEmu Cool Newbie

Joined: Tue Mar 13, 2012 12:23 pm
Posts: 12
No message! Loading until disconnect.
Players on DC and PC.
I was only on Altimira.
I tried myself, and joined a normal team with a second DC (dialup) that works.
No idea since when this happens. I think it started during this week and if i remember right
there where not only one who joined my teams.


Top
 Profile  
 
PostPosted: Thu Apr 12, 2012 5:56 am 
Offline
The Crabby Overlord
The Crabby Overlord
User avatar

Joined: Mon May 27, 2002 9:31 am
Posts: 4097
Are the people joining stuck looking at the pillar in the guild? If so, that means that for whatever reason they didn't get all of the synchronization data from the team leader. In all likelihood, that means that a packet got lost along the way from the leader to the server.

I'm guessing there's an issue with the Dreamcast's network stack where it doesn't resend packets that it should resend. Unfortunately, if that's the case, nothing can be probably be done to fix it. :?


Top
 Profile  
 
PostPosted: Thu Apr 12, 2012 6:37 am 
Offline
DCEmu Cool Newbie
DCEmu Cool Newbie

Joined: Tue Mar 13, 2012 12:23 pm
Posts: 12
Well, perhabs Rolf, SynTexError, or Negus read this and can tell us where they stuck ....
I think, yes, they were watching the pillar.

U mean, somehow, my Dreamcast is broken?
Or are there other reasons for this? Perhaps something with my ISP (wich i didnt change)?


edit:

In all ways, i did not get any message, No "players is joining"!
There were a "lag" when they tried, so no item-drop or i couldnt get items
...while they were joining


Top
 Profile  
 
PostPosted: Thu Apr 12, 2012 6:44 am 
Offline
The Crabby Overlord
The Crabby Overlord
User avatar

Joined: Mon May 27, 2002 9:31 am
Posts: 4097
Its not anything to do with your Dreamcast, at least I wouldn't think it would be. Its more likely a problem on your ISPs side.


Top
 Profile  
 
PostPosted: Thu Apr 12, 2012 8:34 am 
Offline
DCEmu Cool Newbie
DCEmu Cool Newbie

Joined: Tue Mar 13, 2012 12:23 pm
Posts: 12
I was able to test it again, only in normal mode all other players were in a challenge ...
And it worked pretty well.

I ll try again later and hope there will be anyone online to test on ulti.

Think i ll be there in 3 to 4 hours from now ...if anyone wants to help


Top
 Profile  
 
PostPosted: Fri Apr 13, 2012 10:38 am 
Offline
Insane DCEmu
Insane DCEmu
User avatar

Joined: Wed Jan 05, 2011 1:15 pm
Posts: 232
Location: California
roman.DC wrote:
In all ways, i did not get any message, No "players is joining"!

If you don't see the message that a new player is joining, your Internet connection experienced some kind of error that caused the joining process to fail. Once this happens, the team you're in is dead, and nobody can join it after that point, so you need to return to the lobby and make a new team. If this happens frequently, the only solution is for you to not make teams. Your connection to the server is too unreliable for you to host games.

_________________
"Fear the HUnewearl."
Image


Top
 Profile  
 
PostPosted: Fri Apr 13, 2012 12:15 pm 
Offline
DCEmu Cool Newbie
DCEmu Cool Newbie

Joined: Tue Mar 13, 2012 12:23 pm
Posts: 12
Hmmm...

We tried yesterday on iselia only, it works on ultimate.
And now while i am writing this, it works on Altimira aswell.

Hope this was only a temporal error


Top
 Profile  
 
PostPosted: Fri Apr 13, 2012 12:56 pm 
Offline
The Crabby Overlord
The Crabby Overlord
User avatar

Joined: Mon May 27, 2002 9:31 am
Posts: 4097
A lot of the time, network-related issues come and go.

Iselia and Altimira are both hosted on the same machine, so if it works on one, it'll generally work on the other.


Top
 Profile  
 
PostPosted: Mon Apr 16, 2012 6:46 am 
Offline
DCEmu Cool Newbie
DCEmu Cool Newbie

Joined: Tue Mar 13, 2012 12:23 pm
Posts: 12
Ok, it seems to work every now and then.

On this weekend some games work pretty good. Other worked over while, but then it broke. We were 3 and after half an hour or more the 4th wasnt able to join.

Its a litle sad, but perhabs it will work for 100% in a while ...

Thanks for your replies.

roman.DC


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 12 posts ] 

All times are UTC - 8 hours [ DST ]


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group