Downtime, and forum software updated to version 3.2

This forum is for the posting of new newsposts, and it stores the site's news and comments archives. Only newsposters have access to post new news in here; if you wish to submit news, please post it in the discussion section for your particular topic. We may choose to move it here as a newspost if we find that it's worthy for the front page.
Post Reply
User avatar
|darc|
DCEmu Webmaster
DCEmu Webmaster
Posts: 16081
Joined: Wed Mar 14, 2001 6:00 pm
Location: New Orleans, LA
Contact:

Downtime, and forum software updated to version 3.2

Post by |darc| » Sat Mar 24, 2018 11:03 pm

We had a few issues with excessive resource usage on our host. Unfortunately, they disabled the site in the middle of the night, a surprise which caught me off guard and as such the site had to remain down as I found the time to fix it.
During the downtime, I took the opportunity to upgrade the phpBB board software to the new 3.2 branch.

Regarding themes....

The default theme is now Elegance.

The subsilver theme most people know as the default theme is available for selection in your User Control Panel . It is, however, a new version of subsilver based upon the now-phpBB-default prosilver theme, and as such, it will look a little different and that means the avatar/rank appears differently and on the right side of the screen.

For dark theme lovers, there is an excellent dark theme called Digi DarkBlue.
It's thinking...
nymus
DC Developer
DC Developer
Posts: 950
Joined: Tue Feb 11, 2003 4:12 pm
Location: In a Dream

Re: Downtime, and forum software updated to version 3.2

Post by nymus » Sat Mar 24, 2018 11:42 pm

Phew! It still works! I've switched to the recommended dark theme, perhaps as a coincidental symbol of my embracing the important parts of my life.

I'm glad everything went smoothly. Thanks for keeping the site running.
Last edited by nymus on Mon Mar 26, 2018 11:15 am, edited 1 time in total.
behold the mind
inspired by Dreamcast
User avatar
BlueCrab
The Crabby Overlord
The Crabby Overlord
Posts: 5323
Joined: Mon May 27, 2002 11:31 am
Location: Sailing the Skies of Arcadia
Contact:

Re: Downtime, and forum software updated to version 3.2

Post by BlueCrab » Sun Mar 25, 2018 1:17 am

Glad to see it's all back up and running nice and smoothly. Hopefully there won't be any further issues after the upgrades.

One (small) thing to note is that the special banners for the top of the page are gone from the Sylverant, reicast, and /dev/null forums.
User avatar
Eviltaco64X
DCEmu Mega Poster
DCEmu Mega Poster
Posts: 1608
Joined: Wed Jun 25, 2008 7:12 pm

Re: Downtime, and forum software updated to version 3.2

Post by Eviltaco64X » Sun Mar 25, 2018 9:47 am

Looking sleeker, phpBB.
User avatar
|darc|
DCEmu Webmaster
DCEmu Webmaster
Posts: 16081
Joined: Wed Mar 14, 2001 6:00 pm
Location: New Orleans, LA
Contact:

Re: Downtime, and forum software updated to version 3.2

Post by |darc| » Sun Mar 25, 2018 11:14 am

Update on the excessive resource usage:

The excessive resource usage was specifically in regards to the site's database, as the SQL DB is quite large.
As a temporary solution I am hosting the database on a secured FreeBSD jail on a box at my home (I have business/server-class internet connection at home). Having the database locally accessible was also ideal for me when upgrading the phpBB software, making it easier to run the CLI upgrade script (which took over a damn hour for this large database) without worrying about web page timeouts, etc.

Looking this morning there are 40-60 "guests" roaming the site. They are all SEO/advertising bots scraping the site for data mining purposes. Not sure if this has been consistent behavior, but there aren't ever more than a handful of real people browsing the site, so this bot behavior is likely the cause of the excessive resource usage. I have added the offending bot to robots.txt and blocked its IP range, so hopefully this will resolve the issue. I will have to keep tabs on site access logs and resource usage more carefully going forward.

If all goes well, I'll be able to migrate the database back to my webhost soon (which will mean more downtime but shouldn't be too bad).
It's thinking...
User avatar
|darc|
DCEmu Webmaster
DCEmu Webmaster
Posts: 16081
Joined: Wed Mar 14, 2001 6:00 pm
Location: New Orleans, LA
Contact:

Re: Downtime, and forum software updated to version 3.2

Post by |darc| » Sun Mar 25, 2018 4:44 pm

MediaWiki was brought up to the latest 1.30 branch.
Dumpcast's separate phpBB board was brought up to the latest 3.2 branch.

After perusing access logs for the week prior to the site being disabled, I believe the excessive resource usage was because of bots/crawlers generating massive amounts of traffic. One marketing bot, AhrefsBot, was generating 65% of all page requests alone. Several bots/crawlers were blocked and/or banned, especially marketing/SEO bots, which have no useful utility for this website, and thus will blocked from crawling it.

I believe the excessive resource usage situation is resolved now, so I migrated the site's database back to the webhost from my home server. Everything should be OK now, just need to tweak a few things like recreate the unique banners for hosted subforums, etc. and I want to clean up/better organize files on the backend.

Please let me know if you run into any errors or problems!
It's thinking...
User avatar
Aleron Ives
DCEmu Nutter
DCEmu Nutter
Posts: 755
Joined: Wed Jan 05, 2011 2:15 pm
Location: California
Contact:

Re: Downtime, and forum software updated to version 3.2

Post by Aleron Ives » Sat Apr 28, 2018 5:29 am

Spoilers and code boxes no longer work properly with the subsilver theme. If a post has multiple spoilers, clicking "Show" on any of them will only show the first spoiler's contents, so seeing the other spoilers' contents is impossible without viewing page source or quoting the post, removing the spoiler tags, and previewing the message.

Code boxes mostly work, but they no longer have any word wrapping functionality, so text without newlines will appear on one giant line. Both Firefox and Seamonkey are broken for me, but I don't have any non-Mozilla browsers to test.
"Fear the HUnewearl."
Image
User avatar
BlueCrab
The Crabby Overlord
The Crabby Overlord
Posts: 5323
Joined: Mon May 27, 2002 11:31 am
Location: Sailing the Skies of Arcadia
Contact:

Re: Downtime, and forum software updated to version 3.2

Post by BlueCrab » Sun Apr 29, 2018 1:11 pm

I just fixed the spoiler tag issue, I think... Test it out and let me know if it's not working.

As for the code tag, considering its use, I'd think that it should not automatically wrap text myself (since it is supposed to be used for pre-formatted text).

That said, I've just added a variant on the code tag that will do automatic word wrapping as well: wrapped-code:
This is just a test to see if really long lines of code do indeed wrap or not. Of course, I normally write code and documentation such that there is no more than 80 characters per line, for comfortable display on a terminal, but not everyone does that. So, this should have word-wrapped at some point, let's see if it did...
User avatar
Aleron Ives
DCEmu Nutter
DCEmu Nutter
Posts: 755
Joined: Wed Jan 05, 2011 2:15 pm
Location: California
Contact:

Re: Downtime, and forum software updated to version 3.2

Post by Aleron Ives » Sun Apr 29, 2018 7:45 pm

Yep, spoilers work now. The new codebox does work, but it doesn't really solve the problem, as all codeboxes in posts made before the forum update are still broken. Forum codeboxes aren't just for posting computer code; they're also used for posting anything that requires a monospace font for alignment purposes, as well as to just make long text blocks take up less vertical space on the forum, as codeboxes have their own vertical scrollbar. IMO the wrapping behaviour should be restored for the original code tag, as that's how codeboxes worked on the old phpBB software (and pretty much every forum that has a codebox tag).
"Fear the HUnewearl."
Image
User avatar
mankrip
DCEmu Ex-Mod
DCEmu Ex-Mod
Posts: 3694
Joined: Sun Nov 04, 2001 5:12 pm
Contact:

Re: Downtime, and forum software updated to version 3.2

Post by mankrip » Wed May 02, 2018 7:44 pm

The link to the "view active topics" page is missing in this new layout. The page still works, but there's no way to reach it without manually entering its URL.

[edit] Oh crap, it's in a drop-down menu in the blue bar!
Ph'nglui mglw'nafh mankrip Hell's end wgah'nagl fhtagn.
==-=-=-=-=-=-=-=-=-=-==
Dev blog / Twitter / YouTube
Image
Post Reply